スポンサーサイト

  • --/--/--(--) --:--:--

上記の広告は1ヶ月以上更新のないブログに表示されています。
新しい記事を書く事で広告が消せます。

はてなにはコメントできないので、こちらに[追記]

  • 2010/05/13(木) 08:48:11

http://d.hatena.ne.jp/kadotanimitsuru/20100501/MMDforXNA

使ってくれてありがとうございます(はてなブックマークにコメントできないので、こちらで対処)

バグ報告thx。

しかし、なんだろう?このバグ

プログラム自体は止まらずに動いているということは
GPUの方で何かバグったと考えられるのですが……

ネギで落ちるとは考えられないし……
シェーダ3.0に対応しているマシンですし……

今、バグ取りしているので(別の大きめのバグ)
v1.3でなおればいいのですが。

ちょっと原因が掴めないなぁ……
なんだろう?

(追記)
ちょっとこのバグは潰しておきたいので
詳しいこと知りたいのですが……

(追記その2)
http://d.hatena.ne.jp/kadotanimitsuru/20100513/NegiNegiDance
調べてくださって本当にありがとうございます。
コンテントパイプライン中でのベイクバグですか……
しかもDemo2の左側は上手くいっている(左側も実行時にベイクはしていて、同じルーチン使い回しているので)
またパイプラインか……
ヒントは頂けたので、あとは潰せるかどうか……
モデルの質感異常の修正等も含めてバグ潰し加速しなきゃ……

他、結構バグやズレ等を修正中&高速化中なので
次版はもうちょっとお待ちください^^;

スポンサーサイト

この記事に対するトラックバック

この記事のトラックバックURL

この記事にトラックバックする(FC2ブログユーザー)

[animation]例の誤動作の原因が分かった

MikuMikuDance for XNA - つちのこ、のこのこ。(はてな番外地) というか、問題の在処が分かっただけですが。 MikuMikuDanceXNADemo1 ~ MikuMikuDanceXNADemo3 までは順調に動作したのですが……。 MikuMikuDance for XNA - つちのこ、のこのこ。(はてな番外地) というこの

  • From: つちのこ、のこのこ。(はてな番外地) |
  • 2010/05/13(木) 07:37:26

この記事に対するコメント

つちのこ、のこのこ。(はてな番外地) です

トラックバックありがとうございます。

XNA(というか VisualStudio)自体、いじり始めたばかりなので基本的な部分でこちらが間違っている/勘違いしている可能性の方を疑っていたのですが、とりあえずの報告として。

ソリューション「MikuMikuDanceXNA」を読み込んだときに警告が山ほど出、それが後に 0 になり、最後に 2 つのエラー

エラー 1 型または名前空間名 'Accessory' は名前空間 'MikuMikuDance.XNA' に存在しません。アセンブリ参照が不足しています。 C:XNAMMDMMDX-v1.20a-srcMikuMikuDanceXNADemo4Game1.cs 15 25 MikuMikuDanceXNADemo4
エラー 2 型または名前空間名 'Accessory' は名前空間 'MikuMikuDance.XNA' に存在しません。アセンブリ参照が不足しています。 C:XNAMMDMMDX-v1.20a-srcMikuMikuDanceXNADemo5Game1.cs 17 25 MikuMikuDanceXNADemo5

が残ります。

何かの(こちらで手動でやるべき)設定が足りていないのかも?

  • 投稿者: kadotanimitsuru
  • 2010/05/01(土) 22:45:07
  • [編集]

コメントありがとうございます

あれ?なんでDemo4とDemo5からMMDXへの参照が消えているんだろう?
とりあえず、ビルドしてみて通るかどうか確認して下さい。もしかしたらビルドしてないのが理由なのかもしれません。
もし、XBoxへの接続がどうたらこうたら、って出るなら上の方のMixed Platformをx86にして見てください
また、Accessoryは名前空間にどうたらこうたら、がもう一度出るようでしたら、参照設定を再設定してみてください。
再設定方法はDemo4, Demo5内の参照設定内にあるMikuMikuDanceXNAへの参照を消して、参照設定右クリック→参照設定の追加でプロジェクトタブ→MikuMikuDanceXNAというやり方です。
ちなみにXBox360用の~とついているのはXBox用ですので、そちらはXBox360用の~というのから参照するようにしてください。

あと、Content内にも参照設定がありますが、今回の問題とは関係なさそうなのでそちらはいじらないで下さい。

  • 投稿者: ウィルフレムP
  • 2010/05/02(日) 10:02:13
  • [編集]

あとバグ報告について

あと、見せてもらいました。
モーションが完全に止まって、バグってますね……
CPUでNaNをうっかり出してるのか
GPUの方でなんかミスをしたか……

  • 投稿者: ウィルフレムP
  • 2010/05/02(日) 10:05:18
  • [編集]

試してみました

今まではいきなり「デバッグ開始」して出来上がった .exe を実行していたのですが。
ビルド/リビルドしてからの実行、および個別の「~Demo?」にスタートアッププロジェクトを変更してでのビルド/リビルドと、右クリックからの「デバッグ > 新しいインスタンスを開始」を試してみました。(上記、参照設定の再設定もしてあります)

MikuMikuDanceXNADemo4 については以前と変わりなかったのですが。

MikuMikuDanceXNADemo5 で 1度だけ正常動作(ミクも消えずその場に留まって歩行)してくれましたのですが、もう一度同じ操作をしても前の通りにバグっている状態になり、それを再現できません。

いずれの場合でもエラー一覧には何も表示されない状態です。

以上ご報告までに。

  • 投稿者: kadotanimitsuru
  • 2010/05/02(日) 12:00:18
  • [編集]

No title

デバッグ実行で落ちてない、ってことか。
しかも、動くときもあるパターンか……
頭痛いバグだなぁ……

Demo1~3はまともに動作して4, 5が動作しないのかな?

とすると、犯人やっぱりネギ?(え
でもネギでなるはずはないのだけど……

  • 投稿者: ウィルフレムP
  • 2010/05/02(日) 12:26:47
  • [編集]

コメント投稿

管理者にだけ表示を許可する

上記広告は1ヶ月以上更新のないブログに表示されています。新しい記事を書くことで広告を消せます。